Frequently Asked Questions (FAQ)

Q1 : Will this plugin work without Gallery3?
A : Sorry No, Gallery3 is required.

Q2 : Can you explain exactely the « Base URL of the REST API acces of Gallery 3 ?

A: The main page of your Gallery3 website is, normally, accessible with an URL like http://my.gallery3.com/index.php/ , if you don’t active any the rewrite rule in the configuration of your Gallery3’s installation.

So, the « Base URL of the REST API acces of Gallery 3″ would be http://my.gallery3.com/index.php/rest/item .

Q3 : How to set up the guest acces of REST API’s Gallery3 interface ?

A : In the advanced configuration of Gallery3 “allow_guest_access” must equal to “1” : go to Admin » Settings » Advanced and change the “allow_guest_access” parameter of the “rest” module from “0” to “1” (Source).

Q4 : Everything seems to be OK in the config, but I don’t see the button when writing a post… What’s happend ?

A : The G3 button is displayed with the visual mode when editing a post, not in the HTML mode.


Q4 : How to enable the REST API Module in the configuration of Gallery3 ?

A : Log in your Gallery3 with an admin user.

Go into the following section : Admin > Modules, then check the checkbox for the REST API Module.

Q5 : WordPress takes a very long time to load all the pictures and thumbnails … what’s happend ?

A : Take a look at this plan of flows between Gallery3 and WordPress.

All pictures came from your Gallery3. It is not due to WordPress or this plugin.

flows between Gallery3 | WordPress | Plugin Heiv Gallery 3

flows between Gallery3 | WordPress | Plugin Heiv Gallery 3

FacebookLinkedInShare/Bookmark

30 comments

  • Ehran (7 years)

    Hi,

    doesnt seem to be working for me… I get the list of 1st level albums but then not the list of sub albums of images in an album…

    thanks
    ehran

    • HeiV (7 years)

      Hi Ehran,

      Have you set the access read & browse the sub albums for the configured user in the G3’s setting in your wordpress ?

      HeiV

  • Darius (7 years)

    Hi HeiV,

    First of all A++ for you component. It is really elegant and nice to use. The photo’s are perfectly integrated in our website. Thank you for the great work! However, the speed of loading of pages is extremely low. It takes about 30sec to load an album preview. Is this a known issue? Anyway to speedup the loading?
    Each time I click on an album and enter a new hierarchy it again takes quite some time to load.
    I now use anonymous REST access. Should I switch to authenticated access? I’m using the “dir” render object, but “smoothgallery” also gave me the same problem.
    Please advise!

    • HeiV (7 years)

      Hi Darius and thank you for your support.

      Can you tell me the number version of the installed G3 plugin ?

      If you are in the version 0.2.4.3.1, did you activate the cache system ?

      For the next version, I will handle this problem of big album (ton of pictures in one album).

      The only one advice I can give you it is to have “small” albums.

      • Darius (7 years)

        Hi HeiV! I have installed the latest version. The cache time was set to 3600, so it should be ok for consecutive calls I think.
        My album is indeed filled with a lot of images, but surely calling only six albums should not take too long? Also if the thumbs are cached then it should be lightning fast I would say.
        Could we make the cache system any smarter? Perhaps by checking if the album image has changed? I haven’t looked at the code yet, so perhaps I’m talking BS here.
        If you want I could help you with debugging or at least profiling this issue? Is there something I can check? I need a bit of help to get started in your code…

        TIA, Darius

        • HeiV (7 years)

          Ok, good news.

          The plugin only caches the metadata from the restful “socket” of G3 ; the pictures and thumbnails are normally cached by your webbrowser and depend on G3’s caching rules.

          When I will have 2 sec, I will draw a plan of the flows between G3 and this plugin.

          • Darius (7 years)

            Shouldn’t the plugin cache thumbnails as well? In that case you will speedup independent of individual sessions. Let’s say a user opens the foto gallery then a second user will benefit from the cached information. I couldn’t find any information about G3 caching. Do they cache thumbnails? I doubt it to be honest.
            I’m eagerly awaiting your flow diagram. I will make some time avail to help you debug and implement a better G3 plugin. Just let me know how to proceed from here.

          • HeiV (7 years)

            Hi Darius,

            I had a question about the long time for displaying huge albums and you will find the flow diagram.

            Ok for the help you could provide for debug, I have to write some code before :)

  • aaron (7 years)

    Is it possible to display photo captions as well as or instead of the title?

    • HeiV (7 years)

      Hi Aaron,

      Sorry, I don’t see what you want to change. Can you explain more yours needs ?

      HeiV

  • Vi (7 years)

    HeiV,

    Can you help in my situation?
    I created special user for connecting to G3 using your plugin.
    That user is assigned to “Registered Users” group and that group can view all folders in the gallery. I tested it by logging with that user to Gallery3 and it works.
    On wordpress side I entered this user details, your plugin got RESTFul API ticket. Plugin test shows thumbnails of the top galleries. It looks ok.
    But at the time I want insert it into post all I can see is this
    http://www.worldinsnapshots.com/blog/WP_Gallery3.PNG
    these are top galleries and there is no access to sub-galleries and the pictures.
    thank you

    • HeiV (7 years)

      Hi Vi,

      Can you help in my situation?

      Now, no I can’t help you…

      But, your problem will be handled with the next version of this plugin (I hope) ; this version will be released the May, 1st 2012.

      HeiV

      • Vi (7 years)

        So it is know problem? OK, I’ll wait couple weeks :)

        • HeiV (7 years)

          It is not really a problem… It is a missing feature with a specific configuration of Gallery3 / my plugin.

          • Vi (7 years)

            I updated to latest plugin, but I am getting these error:
            Warning: include_once(HTTP/Request2.php) [function.include-once]: failed to open stream: No such file or directory in /plugins/heiv-gallery-3/heiv-gallery_3.php on line 43
            Warning: include_once() [function.include]: Failed opening ‘HTTP/Request2.php’ for inclusion (include_path=’.:/usr/lib/php5′) in /plugins/heiv-gallery-3/heiv-gallery_3.php on line 43

          • HeiV (7 years)

            Hi Vi,

            Yes I see it today.

            Does the plugin work normally for you ?

            HeiV

      • Vi (7 years)

        Hi HeiV,

        No progress. The same issue – test is OK, but in the post it shows only root folder and no pictures.
        I am using default WP theme, so shouldn’t be something special. Don’t understand what is wrong with setup.

        • HeiV (7 years)

          Hi Vi,

          Did you check “on” the proxying mode and try again the picker ?

          HeiV

  • onerock (7 years)

    I am attempting to use the shortcode [hgallery3 id="10" render="dir"]
    I need larger thumbnails, but find that anything that is larger than 220px are cut down and overlapping. I verified with Firebug that changing the height pixels below corrects the issue. I have attempted to change/upload various CSS files but doesn’t seem to what to “stick”. After each change the height parameter remains at 220px. Can anyone give me any advice on making this change. I am looking for a thumbnail size of 202w by 270h.

    .hg3_s_dir_alb {
    float: left;
    margin: 3px;
    text-align: center;
    width: 220px;
    height: 220px;
    display: block;

    I appreciate any assistance that can be provided.

    • HeiV (7 years)

      Hi,

      Did you delete all your browser’s cache ?

      Can you give me an URL in order to see your problem ?
      You could send me an email moi @ heiv.fr if you don’t want to put it in a comment.

      HeiV

      • onerock (7 years)

        Thanks so much for your assistance. I have sent you a link to a test page. I believe that I have cleared all cache that might affect this page.

  • Vi (7 years)

    No. When I did test settings, I got one more error (besides those two above)

    Fatal error: Class ‘HTTP_Request’ not found in plugins/heiv-gallery-3/heiv-gallery_3.php on line 1012

    • HeiV (7 years)

      Oh Oh … I forgot to update the test function…

      Sorry I will fix this !

  • Vi (7 years)

    Can you also fix first two errors?

    • HeiV (7 years)

      I am looking for the library errors.

      Then I will see for this 2 errors in the tracelog.

  • webbmonster (7 years)

    thanks for a crucial plugin. the only slight problem i have is that i get the main picture then a smaller thumbnail picture below it, is there a way of getting just the one picture in WordPress.org

    Many thanks

    • Aaron Lynch (6 years)

      I have the same problem.

      • HeiV (6 years)

        Hi Aaron,

        Did you set something for all the parameters for all the skins in the settings ?

        HeiV

  • Paste (7 years)

    Hi HeiV,

    I saw your awesome plugin and I tried to integrate it, but I have an issue with it: It is not caching the G3, the directory wp-content/plugins/heiv-gallery-3/cache/imgs/ is empty.

    Can you assist / support me to solve the problem?

    Thank you and best regards,

    Henning

    • HeiV (6 years)

      Hi Henning,

      Do you set the write right for the apache user ?

      HeiV

Leave a Reply to Vi Cancel reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Go to Top